upgrading from Plone 3.2.2 to 3.3.4 does not upgrade zope? (windows platform)

classic Classic list List threaded Threaded
2 messages Options
llcolombo llcolombo
Reply | Threaded
Open this post in threaded view
|

upgrading from Plone 3.2.2 to 3.3.4 does not upgrade zope? (windows platform)

Hi all
I have tried to migrate a windows installation of Plone from 3.2.2 to 3.3.4.
I first followed the tutorial
http://plone.org/documentation/manual/upgrade-guide/version/upgrading-from-3-x-to-3.2
which just suggested to modify buildout.cgf to meet the required plone
version.
Everything appeared to work fine and I also migrated all the sites in the
instance, but then I realised that the Control Panel in zmi was still
showing
Zope Version  (Zope 2.10.7-final, python 2.4.4, win32)

I then run the windows installer, but I got to the same result.

How shall I proceed in order to upgrade zope to 2.10.11?

thanks & bye
Lucia



_______________________________________________
Setup mailing list
[hidden email]
http://lists.plone.org/mailman/listinfo/setup
Graham Perrin Graham Perrin
Reply | Threaded
Open this post in threaded view
|

upgrading from Plone 3.2.2 to 3.3.4 does not upgrade zope? — gap in documentation, and a bug with Zope 2.10.11

Focus on the [zope2] section of your buildout .cfg file for Plone 3.3.4.

If you find a line
url = http://www.zope.org/Products/Zope/2.10.7/Zope-2.10.7-final.tgz

then replace that one line with the two lines that follow:
url = http://www.zope.org/Products/Zope/2.10.9/Zope-2.10.9-final.tgz
# url = ${versions:zope2-url}

Explanations:

<http://dev.plone.org/plone/ticket/10110> outlines a gap in documentation.

<http://dist.plone.org/release/3.3.4/versions.cfg> specifies version 2.10.11 but installation of that version may be without a version.txt file. Plone 3.3.4 control panle displays wrong Zope version? and other topics relate. I don't know whether it's safe to work with an undetectable version of Zope.

Until we know whether it's good to continue with installation of 2.10.11 that's bugged in this way, my /guess/ is that we should restrict ourselves to 2.10.9.

If we learn that 2.10.11 is OK to use, then you can remove the comment from the line
# url = ${versions:zope2-url}
and remove the line that specifies 2.10.9.

Regards
Graham