read-only-database on, but can still edit in Plone

classic Classic list List threaded Threaded
3 messages Options
René Pijlman-3 René Pijlman-3
Reply | Threaded
Open this post in threaded view
|

read-only-database on, but can still edit in Plone

In preparation for the upgrade to 2.1.1 I'm trying to make my
production instance of Plone 2.0.5 read-only.

In zope.conf of my instance I configured:

    read-only-database on
    enable-product-installation off

And I restarted Zope.

Yet I can still login to Plone, modify pages and save the
result. What may be causing this?

When I also make Data.fs read-only on the filesystem (chmod a-r
Data.fs) and restart Zope, it fails to start. Which makes sense
if it still tries to open Data.fs read-write.

I'm using Plone 2.0.5 and Zope 2.7.3 on Linux.

--
Rene Pijlman
http://www.applinet.nl/
 


-------------------------------------------------------
This SF.Net email is sponsored by the JBoss Inc.  Get Certified Today
Register for a JBoss Training Course.  Free Certification Exam
for All Training Attendees Through End of 2005. For more info visit:
<a href="http://ads.osdn.com/?ad_idv28&alloc_id845&op=click">http://ads.osdn.com/?ad_idv28&alloc_id845&op=click
_______________________________________________
Plone-Users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/plone-users
redcor redcor
Reply | Threaded
Open this post in threaded view
|

Re: read-only-database on, but can still edit in Plone

Rene Pijlman wrote:

> In preparation for the upgrade to 2.1.1 I'm trying to make my
> production instance of Plone 2.0.5 read-only.
>
> In zope.conf of my instance I configured:
>
>     read-only-database on
>     enable-product-installation off
>
> And I restarted Zope.
>
> Yet I can still login to Plone, modify pages and save the
> result. What may be causing this?
>
> When I also make Data.fs read-only on the filesystem (chmod a-r
> Data.fs) and restart Zope, it fails to start. Which makes sense
> if it still tries to open Data.fs read-write.
>  
this is not right. When you start zope/plone from a CD, Data.fs is read
only.
I was involved in project to create a read only version of a site.
As I remember there are some products that write to the Data.fs at start up.
I think it formulator was the culprit.

robert
> I'm using Plone 2.0.5 and Zope 2.7.3 on Linux.
>
>  



-------------------------------------------------------
This SF.Net email is sponsored by the JBoss Inc.  Get Certified Today
Register for a JBoss Training Course.  Free Certification Exam
for All Training Attendees Through End of 2005. For more info visit:
http://ads.osdn.com/?ad_id=7628&alloc_id=16845&op=click
_______________________________________________
Plone-Users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/plone-users
Dieter Maurer Dieter Maurer
Reply | Threaded
Open this post in threaded view
|

Re: read-only-database on, but can still edit in Plone

In reply to this post by René Pijlman-3
Rene Pijlman wrote at 2005-11-20 11:28 +0100:

>In preparation for the upgrade to 2.1.1 I'm trying to make my
>production instance of Plone 2.0.5 read-only.
>
>In zope.conf of my instance I configured:
>
>    read-only-database on
>    enable-product-installation off
>
>And I restarted Zope.
>
>Yet I can still login to Plone, modify pages and save the
>result. What may be causing this?

"read-only-database" does not work as you (and one) expects.

To get something read only, you should mark the corresponding
storage read only.

--
Dieter


-------------------------------------------------------
This SF.Net email is sponsored by the JBoss Inc.  Get Certified Today
Register for a JBoss Training Course.  Free Certification Exam
for All Training Attendees Through End of 2005. For more info visit:
http://ads.osdn.com/?ad_id=7628&alloc_id=16845&op=click
_______________________________________________
Plone-Users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/plone-users