TinyMCE compatibility chart?

classic Classic list List threaded Threaded
3 messages Options
hvelarde hvelarde
Reply | Threaded
Open this post in threaded view
|

TinyMCE compatibility chart?

seems to me we have 2 branches of Products.TinyMCE being maintained:
1.3.x and 1.4.x; can someone please clarify me the compatibility against
different versions of Plone?

Plone 4.2 uses Products.TinyMCE 1.2.x but it seems to be buggy; can I
use 1.3.x with it? what about 1.4.x?

I don't see this clearly documented.

please remember the right place to put this information is the setup.py
script of your package using classifiers.

best regards
--
Héctor Velarde



------------------------------------------------------------------------------
Slashdot TV.  
Video for Nerds.  Stuff that matters.
http://tv.slashdot.org/
_______________________________________________
Plone-developers mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/plone-developers

smime.p7s (5K) Download Attachment
Luca Fabbri Luca Fabbri
Reply | Threaded
Open this post in threaded view
|

Re: TinyMCE compatibility chart?

On Tue, Sep 2, 2014 at 6:44 PM, Héctor Velarde <[hidden email]> wrote:
> seems to me we have 2 branches of Products.TinyMCE being maintained: 1.3.x
> and 1.4.x; can someone please clarify me the compatibility against different
> versions of Plone?
>
> Plone 4.2 uses Products.TinyMCE 1.2.x but it seems to be buggy; can I use
> 1.3.x with it? what about 1.4.x?
>

For what I remember originally you were able to use Products.TinyMCE
1.3 also on Plone 4.2 and Plone 3.3 (manual upgrade steps are needed).
Not sure if this is still true today.
About 1.4: don't know but I don't think so.

> I don't see this clearly documented.
>
> please remember the right place to put this information is the setup.py
> script of your package using classifiers.
>

Yeah, having an empty pypi page is bad. Luckily TinyMCE is the only
example of this (in the Plone world)



--
-- luca

twitter: http://twitter.com/keul
linkedin: http://linkedin.com/in/lucafbb
blog: http://blog.keul.it/

------------------------------------------------------------------------------
Slashdot TV.  
Video for Nerds.  Stuff that matters.
http://tv.slashdot.org/
_______________________________________________
Plone-developers mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/plone-developers
hvelarde hvelarde
Reply | Threaded
Open this post in threaded view
|

Re: TinyMCE compatibility chart?

On 02-09-2014 18:46, Luca Fabbri wrote:

> On Tue, Sep 2, 2014 at 6:44 PM, Héctor Velarde <[hidden email]> wrote:
>> seems to me we have 2 branches of Products.TinyMCE being maintained: 1.3.x
>> and 1.4.x; can someone please clarify me the compatibility against different
>> versions of Plone?
>>
>> Plone 4.2 uses Products.TinyMCE 1.2.x but it seems to be buggy; can I use
>> 1.3.x with it? what about 1.4.x?
>>
>
> For what I remember originally you were able to use Products.TinyMCE
> 1.3 also on Plone 4.2 and Plone 3.3 (manual upgrade steps are needed).
> Not sure if this is still true today.
> About 1.4: don't know but I don't think so.
HV> yes, compatibility was broken with this commit:

https://github.com/plone/Products.TinyMCE/commit/fe5392343dec32eace38ba406da4c5c02518a9f0

so seems that we can still use Products.TinyMCE up to version 1.3.5 in
Plone 4.2.


------------------------------------------------------------------------------
Download BIRT iHub F-Type - The Free Enterprise-Grade BIRT Server
from Actuate! Instantly Supercharge Your Business Reports and Dashboards
with Interactivity, Sharing, Native Excel Exports, App Integration & more
Get technology previously reserved for billion-dollar corporations, FREE
http://pubads.g.doubleclick.net/gampad/clk?id=190641631&iu=/4140/ostg.clktrk
_______________________________________________
Plone-developers mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/plone-developers

smime.p7s (5K) Download Attachment