Plone 3.3.5 or 3.3.6

classic Classic list List threaded Threaded
4 messages Options
hanssa hanssa
Reply | Threaded
Open this post in threaded view
|

Plone 3.3.5 or 3.3.6

Hi

I have a a few plone-sites running plone 3.3.5 on OpenSUSE 10.2. Now I want to have these running on ubuntu.

Now I am on ubuntu server 10.04 LTS, and will uppgrade the OS as soon as I have the plone site up running.

Strugling with different versions of "eggs". The default installation works fine, but as soon as I try to run buildout with my config there are problems. I try to spesify versions of eggs but I do not succeed.

Is there a way of doing this as it was a few years ago, with the same versions?

My buildout are (the modifications):

eggs =
Plone
heddex.cityportal <1.2
quintagroup.seoptimizer >3.0,<4.0
collective.prettyphoto <0.3.5
collective.portlet.adsense <0.6
quintagroup.plonegooglesitemaps
collective.simplesocial <1.5

zcml =
heddex.cityportal
quintagroup.seoptimizer
collective.portlet.adsense

The previos version, on OpenSUSE:

eggs =
    Plone
    heddex.cityportal
    quintagroup.seoptimizer >3.0,<4.0
    collective.prettyphoto
    collective.portlet.adsense
    quintagroup.plonegooglesitemaps
    collective.simplesocial

everything else is the same.

Running buildout on ubuntu:

Updating zope2.
Updating fake eggs
Updating productdistros.
Installing instance.
Getting distribution for 'zope.browserpage'.
Traceback (most recent call last):
  File "<string>", line 1, in ?
  File "/usr/local/Plone/3.3.6/Python-2.4/lib/python2.4/site-packages/setuptools-0.6c11-py2.4.egg/setuptools/command/easy_install.py", line 1712, in main
    with_ei_usage(lambda:
  File "/usr/local/Plone/3.3.6/Python-2.4/lib/python2.4/site-packages/setuptools-0.6c11-py2.4.egg/setuptools/command/easy_install.py", line 1700, in with_ei_usage
    return f()
  File "/usr/local/Plone/3.3.6/Python-2.4/lib/python2.4/site-packages/setuptools-0.6c11-py2.4.egg/setuptools/command/easy_install.py", line 1716, in <lambda>
    distclass=DistributionWithoutHelpCommands, **kw
  File "/usr/local/Plone/3.3.6/Python-2.4/lib/python2.4/distutils/core.py", line 149, in setup
    dist.run_commands()
  File "/usr/local/Plone/3.3.6/Python-2.4/lib/python2.4/distutils/dist.py", line 946, in run_commands
    self.run_command(cmd)
  File "/usr/local/Plone/3.3.6/Python-2.4/lib/python2.4/distutils/dist.py", line 966, in run_command
    cmd_obj.run()
  File "/usr/local/Plone/3.3.6/Python-2.4/lib/python2.4/site-packages/setuptools-0.6c11-py2.4.egg/setuptools/command/easy_install.py", line 211, in run
    self.easy_install(spec, not self.no_deps)
  File "/usr/local/Plone/3.3.6/Python-2.4/lib/python2.4/site-packages/setuptools-0.6c11-py2.4.egg/setuptools/command/easy_install.py", line 427, in easy_install
    return self.install_item(None, spec, tmpdir, deps, True)
  File "/usr/local/Plone/3.3.6/Python-2.4/lib/python2.4/site-packages/setuptools-0.6c11-py2.4.egg/setuptools/command/easy_install.py", line 476, in install_item
    dists = self.install_eggs(spec, download, tmpdir)
  File "/usr/local/Plone/3.3.6/Python-2.4/lib/python2.4/site-packages/setuptools-0.6c11-py2.4.egg/setuptools/command/easy_install.py", line 655, in install_eggs
    return self.build_and_install(setup_script, setup_base)
  File "/usr/local/Plone/3.3.6/Python-2.4/lib/python2.4/site-packages/setuptools-0.6c11-py2.4.egg/setuptools/command/easy_install.py", line 930, in build_and_install
    self.run_setup(setup_script, setup_base, args)
  File "/usr/local/Plone/3.3.6/Python-2.4/lib/python2.4/site-packages/setuptools-0.6c11-py2.4.egg/setuptools/command/easy_install.py", line 919, in run_setup
    run_setup(setup_script, args)
  File "/usr/local/Plone/3.3.6/Python-2.4/lib/python2.4/site-packages/setuptools-0.6c11-py2.4.egg/setuptools/sandbox.py", line 61, in run_setup
    DirectorySandbox(setup_dir).run(
  File "/usr/local/Plone/3.3.6/Python-2.4/lib/python2.4/site-packages/setuptools-0.6c11-py2.4.egg/setuptools/sandbox.py", line 105, in run
    return func()
  File "/usr/local/Plone/3.3.6/Python-2.4/lib/python2.4/site-packages/setuptools-0.6c11-py2.4.egg/setuptools/sandbox.py", line 64, in <lambda>
    {'__file__':setup_script, '__name__':'__main__'}
  File "setup.py", line 20
    with open(os.path.join(os.path.dirname(__file__), *rnames)) as f:
            ^
SyntaxError: invalid syntax
An error occured when trying to install zope.browserpage 4.1.0.Look above this message for any errors thatwere output by easy_install.
While:
  Installing instance.
  Getting distribution for 'zope.browserpage'.
Error: Couldn't install: zope.browserpage 4.1.0
*************** PICKED VERSIONS ****************
[versions]
collective.portlet.adsense = 0.5
collective.prettyphoto = 0.3.2
collective.simplesocial = 1.5b2
heddex.cityportal = 1.1
quintagroup.canonicalpath = 0.7
quintagroup.plonegooglesitemaps = 1.8.2
quintagroup.seoptimizer = 3.0.7

#Required by:
#quintagroup.plonegooglesitemaps 1.8.2
archetypes.schemaextender = 2.1.5

#Required by:
#collective.simplesocial 1.5b2
collective.autopermission = 1.0b2

#Required by:
#quintagroup.seoptimizer 3.0.7
collective.monkeypatcher = 1.1.1

#Required by:
#plone.app.z3cform 1.1.7
plone.app.textfield = 1.2.6

#Required by:
#collective.simplesocial 1.5b2
plone.app.z3cform = 1.1.7

#Required by:
#quintagroup.plonegooglesitemaps 1.8.2
quintagroup.catalogupdater = 0.1.1

#Required by:
#plone.app.z3cform 1.1.7
zope.globalrequest = 1.1


Any ideas?
---
mvh Hans Sandsdalen

www.sandsdalen.net

_______________________________________________
Setup mailing list
[hidden email]
https://lists.plone.org/mailman/listinfo/plone-setup
Maurits van Rees-3 Maurits van Rees-3
Reply | Threaded
Open this post in threaded view
|

Re: Plone 3.3.5 or 3.3.6

Op 19/12/15 om 18:55 schreef Hans Sandsdalen:

>    File "setup.py", line 20
>      with open(os.path.join(os.path.dirname(__file__), *rnames)) as f:
>              ^
> SyntaxError: invalid syntax
> An error occured when trying to install zope.browserpage 4.1.0.Look
> above this message for any errors thatwere output by easy_install.
> While:
>    Installing instance.
>    Getting distribution for 'zope.browserpage'.
> Error: Couldn't install: zope.browserpage 4.1.0

You are pulling in zope.browserpage 4.1.0 which has code in its setup.py
that is not compatible with Python 2.4.

https://pypi.python.org/pypi/zope.browserpage suggests that the
incompatibility started at version 4.0.0 of this package. The version
before that should be fine.  So in your [versions] section, add this line:

zope.browserpage = 3.12.2

Run bin/buildout again and you should be okay for this package.
It might be that you then simply run into the next problem of this kind.
It is best practive to pin the versions for all packages.

On your old server you may try this command:
bin/buildout -Novvvvv |sed -ne 's/^Picked: //p' | sort | uniq
This *should* change nothing on the file system, but prints out all
packages with their version when they are not pinned yet.

Taken from:
http://maurits.vanrees.org/weblog/archive/2008/01/easily-creating-repeatable-buildouts

More tips: http://docs.plone.org/manage/troubleshooting/buildout.html

BTW, you may get more responses on this online forum:
https://community.plone.org
Most community discussions currently take place there.  We have not shut
down all mailing lists yet or updated the links in all the proper places.


--
Maurits van Rees: http://maurits.vanrees.org/
Zest Software: http://zestsoftware.nl

_______________________________________________
Setup mailing list
[hidden email]
https://lists.plone.org/mailman/listinfo/plone-setup
hanssa hanssa
Reply | Threaded
Open this post in threaded view
|

Re: Plone 3.3.5 or 3.3.6

Hi

I did try this, pin versions, but did not succed. I will try to go directly to 4.0.9.

Thank you for your help... :)

---
mvh Hans Sandsdalen

www.sandsdalen.net

----- On 21 Dec, 2015, at 12:40, Maurits van Rees [hidden email] wrote:

Op 19/12/15 om 18:55 schreef Hans Sandsdalen:

>    File "setup.py", line 20
>      with open(os.path.join(os.path.dirname(__file__), *rnames)) as f:
>              ^
> SyntaxError: invalid syntax
> An error occured when trying to install zope.browserpage 4.1.0.Look
> above this message for any errors thatwere output by easy_install.
> While:
>    Installing instance.
>    Getting distribution for 'zope.browserpage'.
> Error: Couldn't install: zope.browserpage 4.1.0

You are pulling in zope.browserpage 4.1.0 which has code in its setup.py
that is not compatible with Python 2.4.

https://pypi.python.org/pypi/zope.browserpage suggests that the
incompatibility started at version 4.0.0 of this package. The version
before that should be fine.  So in your [versions] section, add this line:

zope.browserpage = 3.12.2

Run bin/buildout again and you should be okay for this package.
It might be that you then simply run into the next problem of this kind.
It is best practive to pin the versions for all packages.

On your old server you may try this command:
bin/buildout -Novvvvv |sed -ne 's/^Picked: //p' | sort | uniq
This *should* change nothing on the file system, but prints out all
packages with their version when they are not pinned yet.

Taken from:
http://maurits.vanrees.org/weblog/archive/2008/01/easily-creating-repeatable-buildouts

More tips: http://docs.plone.org/manage/troubleshooting/buildout.html

BTW, you may get more responses on this online forum:
https://community.plone.org
Most community discussions currently take place there.  We have not shut
down all mailing lists yet or updated the links in all the proper places.


--
Maurits van Rees: http://maurits.vanrees.org/
Zest Software: http://zestsoftware.nl

_______________________________________________
Setup mailing list
[hidden email]
https://lists.plone.org/mailman/listinfo/plone-setup
_______________________________________________
Setup mailing list
[hidden email]
https://lists.plone.org/mailman/listinfo/plone-setup
hanssa hanssa
Reply | Threaded
Open this post in threaded view
|

Re: Plone 3.3.5 or 3.3.6

Hi

Tried once more, and succeeded! Don't know what the difference is, but that is not important!

---
mvh Hans Sandsdalen

www.sandsdalen.net

----- On 21 Dec, 2015, at 19:35, Hans Sandsdalen [hidden email] wrote:

Hi

I did try this, pin versions, but did not succed. I will try to go directly to 4.0.9.

Thank you for your help... :)

---
mvh Hans Sandsdalen

www.sandsdalen.net

----- On 21 Dec, 2015, at 12:40, Maurits van Rees [hidden email] wrote:

Op 19/12/15 om 18:55 schreef Hans Sandsdalen:

>    File "setup.py", line 20
>      with open(os.path.join(os.path.dirname(__file__), *rnames)) as f:
>              ^
> SyntaxError: invalid syntax
> An error occured when trying to install zope.browserpage 4.1.0.Look
> above this message for any errors thatwere output by easy_install.
> While:
>    Installing instance.
>    Getting distribution for 'zope.browserpage'.
> Error: Couldn't install: zope.browserpage 4.1.0

You are pulling in zope.browserpage 4.1.0 which has code in its setup.py
that is not compatible with Python 2.4.

https://pypi.python.org/pypi/zope.browserpage suggests that the
incompatibility started at version 4.0.0 of this package. The version
before that should be fine.  So in your [versions] section, add this line:

zope.browserpage = 3.12.2

Run bin/buildout again and you should be okay for this package.
It might be that you then simply run into the next problem of this kind.
It is best practive to pin the versions for all packages.

On your old server you may try this command:
bin/buildout -Novvvvv |sed -ne 's/^Picked: //p' | sort | uniq
This *should* change nothing on the file system, but prints out all
packages with their version when they are not pinned yet.

Taken from:
http://maurits.vanrees.org/weblog/archive/2008/01/easily-creating-repeatable-buildouts

More tips: http://docs.plone.org/manage/troubleshooting/buildout.html

BTW, you may get more responses on this online forum:
https://community.plone.org
Most community discussions currently take place there.  We have not shut
down all mailing lists yet or updated the links in all the proper places.


--
Maurits van Rees: http://maurits.vanrees.org/
Zest Software: http://zestsoftware.nl

_______________________________________________
Setup mailing list
[hidden email]
https://lists.plone.org/mailman/listinfo/plone-setup
_______________________________________________
Setup mailing list
[hidden email]
https://lists.plone.org/mailman/listinfo/plone-setup